Installing MySQL commercial 5.7 on Clear Linux

I am trying to build up a MySQL commercial edition version 5.7.27 on Clear linux. I have tried using Linux Generic Binaries provided by Oracle (As using RPM failed, and there were no other option) and followed MySQL documentation for its setup and support. Now MySQL starts up, creates default tables needed for its engine and starts listening on 3306. But when I want to connect from clear linux command line, I get the following error :

mysql: error while loading shared libraries: cannot open shared object file: No such file or directory

I’ve seen this problem before. It’s due to not having ncurses-devel package installed. On RHEL/CentOS, you cannot install MySQL RPMs if you don’t have ncurses-devel installed. But using binary packages, there is no dependency-resolution process in place. So this becomes a runtime error. I have tried installing dev-utils and similar packages which seems to have libncurses. I even compiled and installed ncurses from source code, but had no luck.

Any ideas on how to resolve this?

sudo swupd bundle-add compat-common

1 Like