Installing TP link Wn725n WiFi adapter driver

I have a tp link wn725n wifi adapter which has rtl8188eu chipset on it. It works on latest versions of other Linux distro like Pop os out of the box… Plz help me to get it work on clear linux. Tried different 3rd party drivers form github but of no use… The official driver only supports upto kernel version 4.x.x plz do help me…

which driver is it using in the other linux distro’s? You can use sudo ethtool -i <interface> to query the module name.

rlt 8188eu.ko is been used there

We do have an LTS 4.19 kernel you could try. I am not sure if the complete driver is in it, but it is worth a try in the meantime.

sudo swupd bundle-add kernel-lts2018
sudo clr-boot-manager list-kernels
sudo clr-boot-manager set-kernel <kernel you want>
sudo reboot

We ship r8188eu.ko according to our own config. Have you tried to modprobe it? Any sudo dmesg output that’s relevant?

Hello,

I’m new to Linux and do not know how to modprobe it. I did dmesg and got answers like:
[ 1642.448760] usb 1-1: USB disconnect, device number 8
[ 1649.639003] usb 1-2: new high-speed USB device number 9 using xhci_hcd
[ 1649.765393] usb 1-2: New USB device found, idVendor=0bda, idProduct=8179, bcdDevice= 0.00
[ 1649.765399] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1649.765403] usb 1-2: Product: 802.11n NIC
[ 1649.765408] usb 1-2: Manufacturer: Realtek
[ 1649.765410] usb 1-2: SerialNumber: 00E04C0001
[ 1649.770745] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_D_CUT_1T1R_RomVer(0)

Please, help me to connect to wifi.

Why it gives the Realtek when I have connected the same tp-link as in the first post’s photo? When I put it in the Wi-Fi networks appear in the settings but the Select network list is empty.

sudo modprobe r8188eu

gives nothing

It means that this package is installed. Right?

lsmod | grep r8188eu
r8188eu 372736 0
lib80211 16384 1 r8188eu
cfg80211 651264 1 r8188eu

It is running but I have read that manufacturer have changed the chip. That probably means that software is ok and I’m not as hopeless… :frowning: