Question how disable the lcd panel of notebook since boot

I set on gnome 40 to uses only the external display only however the logon screen appears on notebook lcd when I turn on the notebook.
It only turn off after log on clearlinux.

With Windows 10 I don’t have this problem.

Any advice?

Not a direct answer, but I’m using Xfce (with LightDM) and I am able to completely turn off the laptop’s LCD by disabling it as an output in Xfce’s display settings. Everything after the bootloader stage, including the greeter, shows on the external screen.

May be try another greeter/DM just to rule things out?

1 Like