[Solved] PCIe Buss Error

Hello, everyone.

I am trying to get rid of this PCi bus error 0000:00:1c.0 error, but Clear Linux doesn’t really use a grub, which means I need to find some sort of alternative solution. Could anyone help me?

Normally, the solution would be the one here, but sudo gedit /etc/default/grub is just an empty window on Clear Linux.

Thank you kindly!

If you do a man clr-boot-manager there is documentation on where to add additional kernel parameters like this.

1 Like

Thank you, but I changed to linux recently, so I am not that familiar with the terminal or kernels and so on. If you could help me with a step by step guide on how to fix this, that would be amazing and really appreciated! Thank you anyway for telling me about clr-boot-manager

if this is a PCIe ASPM issue, check your BIOS settings - ASPM is usually something you can disable in the BIOS. Of course, you can force disable it as a kernel boot option like you suggested as well.

1 Like

If you don’t have a BIOS setting like @ahkok pointed out:

sudo mkdir -p /etc/kernel/cmdline.d/
echo "pcie_aspm=off" | sudo tee /etc/kernel/cmdline.d/pci-aspm.conf
sudo clr-boot-manager update

If it worked, cat /proc/cmdline should show it at the end.

1 Like

Thank you both for the help. Doing it via terminal helped.