Up, running and very happy

So I’m very happily running Clear Linux on my desktop and my daily driver laptop. I wanted to say thanks and to document my road to getting here in case it helps anyone.

I’ve used Linux as my daily driver OS for a decade or more and have run through the Debian, Ubuntu, Arch, Linux Mint routes with my laptop running Linux Mint most recently since I tend to like Cinnamon. My “play” / does everything machine is a Kaby Lake ITX machine running containers / Proxmox in the basement.

The start of the story is the desktop. I bought it originally as an alternative to a Raspberry PI. It cost $50 and was used as a remote sensor for some RTL-SDR stuff. Of late though, I’ve wanted a larger monitor to do some photo work and this machine was just sitting around. Since my laptop was my day to day machine, I didn’t want to experiment with a new distro there and thus started the quest to get this Sandybridge Beast up and running on Clear. My assumption was that if I could get it up and running, Clear’s performance boost would make it plenty fast enough for what I wanted it for.

So this SFF Lenovo ThinkCenter 71 was of the vintage at the very start of UEFI. It has a UEFI which is half-broken, doesn’t support secure boot and really isn’t terribly configurable. I didn’t have a problem when the machine was running Debian headless since I had booted that machine up on what was apparently a BIOS only image. However when I went to boot up Linux Mint to do benchmarking before installing Clear, it booted UEFI find from the usb key, however wouldn’t boot from the hard disk. After search engine crawling, this particularly Lenovo UEFI is of a vintage that only boots UEFI entries labeled “Windows Boot Manager”. Lovely, but that let me work around things and get the system up to Linux Mint to run Phoronix Benchmarks.

The next challenge was actually far easier. The system originally had a Pentium G620 in it which doesn’t support AES-NI. I bought a I5-2500T to swap out and I could pass the clear compatibility check. Then came the challenge of getting Clear to install.

Again, as with Linux Mint, the USB key booted without and issue but I couldn’t get the system to boot from the hard drive. I added a default “Windows Boot Manager” which fires off Bootx64.efi and starts down that road, however the system continually complained that it couldn’t find the initrd. After another bout of running through search engine results, I determined that again this quality UEFI doesn’t quite have correct FAT support for long filenames. So it would truncate the long kernel or initrd strings and thus systemd-boot couldn’t figure them out. That wasn’t an issue for LM since it ran grub which as I understand it has it’s own fat filesystem support. I was able to work around the issue though essentially by copying the kernel, initrd, etc to shorter filenames. Now as a downside, I have to do this with every kernel upgrade but once done, the system boots and runs beautifully and fast. It does have a broken ACPI implementation which cause the machine to halt but not poweroff on shutdown, but while it is up and running the machine is solid and fast.

Benchmarks showed my Sandybridge 4C/4T desktop matched my Skylake 2C/4T desktop so I ended up converting my laptop over as well. Ironically it also didn’t boot up initially since systemd-boot seems to believe there is a default to bootx64.efi. My system came from Linux to Linux so there was no default to boot bootx64.efi. I had to manually add an entry with efibootmgr (but that was cake after the loops I jumped through with the desktop).

It’s been about two weeks and I’m still getting comfortable with Clear but it’s gone very well. firewalld’s bundle doesn’t seem to depend on having nftables installed so didn’t work by default on either desktop or laptop (I added network-basic and restarted firewalld). And the inkscape bundle seems to error out when importing an .ai file (the Clear Linux logo so I could convert to svg to update my network diagram) but the flatpak worked fine. Firefox and Atom work great and I’m actually liking Gnome to my surprise (although it’s a bit heavy on the ram for some of these older machines). There have been some learning curves - like bundles seem to update automatically but not flatpaks. I’ve also broken down and compiled some software I use often but is only in larger bundles (optipng for example). But I’m sold on this distribution.

I’d like to migrate my lxc containered server over to a Clear Linux install and replace the lxc containers with docker / kata equivalents (or native software). I could probably squeeze a bit more out of that machine which is starting to bump up into resource limits and a dockerized existence would probably simplify my current setup. The problem is that I’d really need another system to start the build out and migrate services over to keep things up and running and I don’t have another system. However I guess that’s part of the process.

Thank you for all your work on this, and I’ll see you out there.

1 Like

Thanks for sharing. It is what makes our work valuable. And welcome to the community!

Hello, I’d like to add to this by saying that I installed Clear Linux for the second time a couple of days ago. The experience has been really good although I believe a few steps can be taken towards ease-of -use of the distro (especially concerning NVIDIA drivers). I’m not an experienced Linux user although I’ve tried quite a few of distros and I have to say, I didn’t think I could find a distro as good as Manjaro Deepin but Clear Linux definitely seems as good. I’m still in the process of setting things up but up to now I have seen better performance overall including gaming on emulator.Really promising distro, keep up the good work. :smiley:

1 Like

Thank you. We appreciate the support. Let us know how everything goes for you, and how we can help.

1 Like

Welcome and thanks for sharing your experience in detail. I applaud your perseverance with that wonky UEFI. I used to have a desktop at one point that behaved similarly. I was glad to get rid of it :slight_smile:

Ah, yes. This will be fixed soon. We were missing a kernel config and a bug upstream: https://github.com/clearlinux/distribution/issues/1123

Let us know what these are and we can work towards making them more granular where it makes sense.
GitHub is a good place to request: https://github.com/clearlinux/distribution/issues

3 Likes

Thank you! Yes, I’ve been looking at several of the issues on github and seeing if there were things I should submit. I’ve been running Clear for a bit over a week though so I figured I should probably get my feet a bit wet first before filing a bunch of enhancement requests. :grinning:

1 Like