USB recognized, but not booting

New Lenovo P53, Booted original windows. Then replaced with two new M.2 SSD., UEFI BIOS version N2NET28W (1.13), 2019-08-27.
Power on, with USB inserted holding clear-31460-live-desktop.iso. F12 to select boot device, USB is offered as an option. Select USB, a brief pause, and it returns to the Boot menu with options for two SSD, the USB, PXE Boot, and Lenovo Cloud. That USB will boot on a Lenovo T510. Testing with an old bootable USB with an older Ubuntu produces the same result.
I think I followed instructions on with UEFI boot enabled.
It must be a setting I am missing. Perhaps an update or something? The old USB installation should have anwered an old UEFI setting question. Maybe there is something that would produce more visibility?

@reiki33 welcome to the Clear Linux forum!

When you go into the UEFI settings, is there an entry for supporting legacy BIOS (probably a checkbox or something)? If there is, make sure to uncheck it. Also, when you look at the bootable devices, do you see the USB device? Also make sure secure boot is disabled.

Sometimes when I use the UEFI boot menu at power-up, there will be multiple entries for the USB device, make sure to select the GPT boot partition.

I found this link on the Lenovo site which provided the clue to override the UEFI setting to “both” for the P53, specifically. Thanks Tom. See you at the next meetup?

1 Like

Yay! Glad you got it working.