Video/display artifacts

Guys, here’s the kind of video artifacts that I am getting with the latest CL releases (40580-40600) on my external monitors through a T4 docking station. Is any of you guys getting this as well? I don’t think I noticed this on my laptop’s built-in monitor, so it may have something to do with USB-attached displays. (And yes, I’ve tried multiple docking stations, same result. Also, I don’t recall seeing this with previous CL releases.)

Yeah, it turns out that there’s something funny going on with the DP ports on the docking station after all:

  1. defective design? (Tried two identical brand new docks.)
  2. dock needs new firmware? (Good luck with that!)
  3. CL doesn’t have the latest drivers for (what I assume is) Goshen Ridge?

Well, no, there’s nothing wrong with that docking station. I am getting that behavior with other docking stations as well, though not all docking stations. It looks like there may be something funny happening with Linux/CL Display Port … drivers? Here’s my setup:

  1. Latest CL on LGGram 2023;
  2. Two 4K monitors connected via DP cable;
  3. Docking station with either two DP ports, or one USB-C to dual DP adapter.

Interestingly, if I connect the DP monitors each to its own USB-C port using two USB-C to single DP adapters, this is not happening!

Am on fresh install of CL 40620, not getting any output at all with DP, and this worked previously on 40600. Only bundles I’ve added so far are


@Kingfisher: U using a docking station?

no docking station, I use a direct dp cable from my gpu straight to my monitor. After updating to CL 40630, it fixed itself. Must’ve been an error in my setup.