VirtualBox: 37310 and up are unbootable

Releases 37300 and lower are working fine under VirtualBox. I am able to install and run either clear–37300–live–desktop from the GUI installer, or clear–37300–live–server in TUI mode and then convert it to desktop. Also tried older 32480 and then updated it to 37300, in both desktop and server editions, they all worked great.

But as soon as I try 37310+, either using direct installation from corresponding ISO(s), or updating to 37310+ from 37300-, Clear Linux becomes unbootable. Notorious black screen.

VirtualBox/Mac 6.1.40, all VM settings are from a github guide (clear-linux-documentation/virtualbox-cl-installer.rst at f6b1c478345958bbe2ff064997b8c13f4b3fee2e · clearlinux/clear-linux-documentation · GitHub). Tried 1, 2, 4 cpus, with or without nested paging, VMSvga or VBoxSvga, nothing helps.

One more detail: live GUI installers of 37310+ are working fine. Installed systems don’t.

Alt+F1-F7 doesn’t work. But it’s possible to login via ttyS0, using telnet and VirtualBox COM–port. I preferred this method of taking dmesg logs instead of " nomodeset" kernel boot parameter, because telnet login doesn’t divert the problematic boot sequence.

dmesg of good 37300: http://ix.io/4fcy
dmesg of problematic 37310: http://ix.io/4fcz

PS. Seems like updated gdm greeter is the troublemaker. If I set up autologin in 37300–desktop, and then update to 37310 or higher, Clear Linux boots to desktop perfectly. But when I log out I see black screen again.

This post was flagged by the community and is temporarily hidden.

1 Like

I also see either install fails or update fails in Clear running in a VM. Be it KVM or VB periodically. Same behavior, install completes but boots to flashing cursor or it updates and reboots to flashing cursor. The builds vary in the behavior and I have stopped tracking them. I simply revert my image and wait until they work down the road

1 Like

I’ve found a workaround to run 37310–37600 desktop in a VirtualBox with VMSVGA+3d acceleration.

  1. In case of problems hit Space button rapidly during early boot stage, then press E to modify kernel boot parameters, append " nomodeset" kernel parameter and boot to text terminal.

  2. Configure GDM to use autologin:
    $ sudo nano /etc/gdm/custom.conf
    [daemon]
    AutomaticLoginEnable=True
    AutomaticLogin=<your_username>

  3. Enforce X11 session instead of Wayland (X11 has fewer problems in newer releases).
    $ sudo nano /var/lib/AccountsService/users/<your_username>

    Session=gnome