Cannot Boot after VMWare

After trying to get VMWare workstation to work I kept getting the " Cannot open /dev/vmmon" error, I followed the steps here: and after importing the key and signing the modules clear linux will not boot. my system was in an unsecure boot mode when I did the above steps. Any suggestions?

Boot messages:
Failed to open \EFI\org.clearlinux\mmx64.efi - Not Found
Failed to load image \EFI\org.clearlinux\mmx64.efi: Not Found
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state() failed: Not Found.

Thank you

do you have to enable secure boot?

Thanks, yea had the same thought.
I tried enabling secure boot but it did not even go into clear, bios error message that the selected boot device failed. disabling secure boot again puts me with the original error message

from my understanding, the article in your link described what to do if you HAD ENABLED secure boot. but you said you DID NOT enable that.

To be clear, can you confirm that you turned of the secure boot in both your physical machine and the virtual machine?

Got the same problems after vmware and/or virtualbox installation on my laptop
From my personal notes:

Optional! In my case without this steps my laptop is not booting anymore

Find your boot partition by running (it will be the smallest one and named “EFI System”)

sudo fdisk -l

Creating mount point for boot partition. In my case boot partition is /dev/nvme0n1p1

sudo mkdir /media/boot && sudo mount /dev/nvme0n1p1 /media/boot/

No idea why, but this worked for me

sudo cp /media/boot/EFI/BOOT/BOOTX64.EFI /media/boot/EFI/org.clearlinux/mmx64.efi