Can't install in my MacBook Air 11 2011 because of EFI

I am unable to install Clear linux on my Macbook Air 11 from 2011 because of EFI ? I have not been able to fix it. What possibilities exist to make the installation work. I used rufus to create the USB. Kudos to the team behind Clear, it is by far the sleekest linux I have tried in a long while, just simply beautiful work. Keep up what you are doing.

I don’t understand your question. MacBook uses EFI to boot, and so as Clear Linux.

What do you mean by “because of EFI”? Any error messages? You could try Etcher to create the boot stick and/or try another usb stick.

Thank you both, I’m sorry if I wasn’t clear. When I boot through ALT I am given three choices when using a USB stick prepared with rufus, that is a macos boot disc, windows (being Clear Linux), and EFI Boot (being Clear Linux). When I chose the windows option it boots a live version of Clear Linux. When I try to install it and the installer starts to do its check, it says EFI fail and doesn’t install it. When I boot from the EFI Boot. it just freezes with a black blank screen.

I also tried balena etcher which at the boot it gives me an option between macos boot disck and EFI boot. When I choose EFI boot it just keeps a black screen without any other prompts like with the one prepared with rufus.

Do you have any ideas on how to get this working? Thank you in advance.

It’s an expected behavior if you see no response at all after you select EFI boot.
What’s the model of your CPU?

It is a Core i5-2467M at 1.6Ghz, with max SC Turbo 2.3Ghz.

Your CPU meets the requirements of Clear Linux.

Can you follow this to check whether you’ve latest EFI BOOT ROM?

It seems the SMC is the same version, but not sure about the ROM version. It also seems to require 10.8m5 or 10.9.5 to update. I am running 10.13.6 High Sierra. Do I need to downgrade to install the updates? Many thanks

No. They are supposed to be upgraded during OS upgrade. I wanted you to verify that in case you are not running macOS.

Since your CPU model meets the requirements, and your EFI BOOT ROM is up to date. I recommend you to re-verify that your installer media is made correctly. Specifically, the live installer needs to boot in UEFI mode, so one possible mistake is you configured Rufus to make it bootable for BIOS, not UEFI.

Etcher, as recommend by tutorial, has virtually no option to customise, and you’re not likely to make any mistakes. So I recommend you to use that instead of Rufus, if you need to re-burn a Live ISO.


Another possible reason for failure is, you previously installed other bootloaders, e.g. Clover and rEFIt, for other OS that requires BIOS to chain-boot.

Thank you. This time around I am using a USB stick prepped with etcher, as described in the instructions. I also did a clean time machine restore of macos previously in a formatted drive. It still doesn’t work :frowning:

I burned an live ISO with etcher and I didn’t see any errors when booting to the ISO on my MacBook Pro 2015.

Thank you for chucking as well. I tired with another USB stick and propped a live USB but still left with a blank screen. I wonder what is causing it or if it is something laptop specific…

Maybe unrelated. But do you have File Vault(disk encryption) enabled?

Could you try this please after installing on the hard drive:

At the beginning of power up press the Esc key several times until you see the UEFI boot screen with Clear Linux.
Press “e” to edit the command
Use right and left arrows to find “quiet” and delete it
Add “nomodeset”
Press enter to run the command

Why do I need nomodset?

You? No. I was responding to sls with a blank screen after installation.

Nevermind… I thought you replied to me.

File vault is turned off.

I am having difficulties installing it. The blank screen comes after I choose uefi at the ciso boot screen

If you reboot and immediately press the Esc key a few times do you get the “Clear Linux” OS select screen?
If so that’s where you would press “e” quickly (within 3 seconds) to edit the run command.