Full RDP is here, finally!

(I wonder whose idea was to skip this feature on the initial release?)

1 Like

I second your question (I wonder whose idea was to skip this feature on the initial release?)

Is this feature available now and does it actually work?

I have spent the last few weeks trying each new build to see if gnome-remote-desktop.service would work or other approaches to GUI based remote desktop login.
I even tried what @kris was suggesting in discussion thread [Problem] Latest Build 40470 Has Issues X-Win Application Crashing

I got a little further with “dbus-run-session startplasma-wayland” in my VMware session, there were
still issues, did not seem to work as a headless (no GUI card/monitor) mode.

It seems like if the remote-desktop.service service this would be the best approach if it would work.

Looks like it’s coming in March, with GNOME 46. I am guessing we (i.e. CL people) will be getting it pretty soon after GNOME 46’s release, as usual. :laughing:

Ok thanks I will look for that change under release notes under latest build gnome is at version 45.2 in the latest build.
Index of /releases/ (clearlinux.org)

At least there is hope, I was almost going to attempt to write my own somewhat gui based client
in Windows to view data from server, kicked off by ssh session commands. Utilities like ssh and sftp are always available. sftp can be used to fetch files from server and used in GUI based editor in windows or other client, then sent back to server via sftp to correct locations.

1 Like

It’s now 3/9/2024. I was hoping to see that gnome was up to version 46 was being released, thereby making a headless RDP session capability available. I guess it is not. What is the schedule now?

swupd info
Distribution: Clear Linux OS
Installed version: 41190
Version URL: https://cdn.download.clearlinux.org/update
Content URL: https://cdn.download.clearlinux.org/update

uname -a
Linux netserver03 6.7.8-1413.native #1 SMP Sat Mar 2 09:56:22 PST 2024 x86_64 GNU/Linux

gnome-shell --version
GNOME Shell 45.4

Hey all my complaint should be directed towards GNOME – Simple, beautiful, elegant.
They are still reporting their latest release as version 45.

A google search asking when gnome version 46 yielded this:
The final release of the GNOME 46 desktop environment is expected on March 20th, 2024 . The GNOME Project announced today the availability of the Release Candidate (RC) milestone of the upcoming GNOME 46 desktop environment series, due out later this month, for public testing

Just adding this for any gnome developers that happen to be supporting gnome develepment:
GNOME 46.beta released - Desktop - GNOME Discourse

Looks like end of March, or beginning of April for us.

When will Clear-Linux version 41280 be available for update? The release notes indicate that gnome
is up to version 46.

date ; swupd check-update
Fri Mar 22 11:05:18 AM PDT 2024
Current OS version: 41230
Latest server version: 41270
There is a new OS version available: 41270

Build 41280 has been around for a day or so. Are there more QA tests to be done?
The latest verson showing release showing is now 41290.

I think there were some KDE issues being worked through - I don’t know if they are causing the delay or if it is something else entirely.

Be patient!


1 Like

The available updates as reported by swupd check-update still indicates
swupd check-update
Current OS version: 41230
Latest server version: 41270
There is a new OS version available: 41270.

I tried the version 41290 (clear-41290-live-desktop.iso) desktop to see if the “headless” gnome desktop would work, it does not. I was able to download bundle that contained: the binary required to
make the headless server work. gnome-remote-desktop. The systemctl command was not
able to start the service gnome-remote-desktop.service service. I then attempted to
starte the binary directly:

root@clr-live~ # dbus-run-session /usr/libexec/gnome-remote-desktop-daemon
dbus-daemon[16174]: [session uid=0 pid=16174] Activating service name=‘org.freedesktop.secrets’ requested by ‘:1.0’ (uid=0 pid=16175 comm=“/usr/libexec/gnome-remote-desktop-daemon”)
dbus-daemon[16174]: [session uid=0 pid=16174] Successfully activated service ‘org.freedesktop.secrets’
dbus-daemon[16174]: [session uid=0 pid=16174] Activating service name=‘org.gtk.vfs.Daemon’ requested by ‘:1.0’ (uid=0 pid=16175 comm=“/usr/libexec/gnome-remote-desktop-daemon”)
dbus-daemon[16174]: [session uid=0 pid=16174] Successfully activated service ‘org.gtk.vfs.Daemon’

Ran ss and netstat did not see that port 3389 (rdp) was enabled and listening or working.
Looks like upgrade to gnome version 46 is going to take a little longer.

How does one configure gnome-remote-desktop to work in a headless server?
I am able to login into the xrdp screen via Mircosoft RDP client, but cannot log into
gnome-desktop. The version is up to the latest see below along with some diagnostics.

swupd info

Distribution: Clear Linux OS
Installed version: 41370
Version URL: https://cdn.download.clearlinux.org/update
Content URL: https://cdn.download.clearlinux.org/update

gnome-shell --version
GNOME Shell 46.0

The right ports are listening
ss -ta
State Recv-Q Send-Q Local Address:Port Peer Address:Port Process
ESTAB 0 0 168.41.1:58354
ESTAB 0 44 [::ffff:]:ssh ffff:]:56476

sudo systemctl enable --user --now gnome-remote-desktop
Failed to connect to bus: No medium found

systemctl status xrdp.service
● xrdp.service - xrdp daemon
Loaded: loaded (/usr/lib/systemd/system/xrdp.service; enabled; preset: disabled)
Active: active (running) since Sat 2024-03-30 11:01:40 PDT; 2h 48min ago
Docs: man:xrdp(8)
Process: 399 ExecStart=/usr/bin/xrdp $XRDP_OPTIONS (code=exited, status=0/SUCCESS)
Main PID: 401 (xrdp)
Tasks: 2 (limit: 4624)
Memory: 18.5M ()
CGroup: /system.slice/xrdp.service
├─401 /usr/bin/xrdp
└─839 /usr/bin/xrdp

  1. I see the same (?) here. I’m only able to RDP into a Gnome session I’m already logged into. The Gnome settings panel for Remote Login has options greyed out. There’s a bug report that looks relevant, but it talks about disabling SELinux, and I’m pretty sure we’re not running that in Clear Linux.



Yeah, it looks like there’s still something missing.

@arjan, @pixelgeek, any thoughts as to what may be happening here?

No idea from me. I don’t think we have a GitHub tracker for this, do we? If not, enter one and smile nicely at the dev team?

1 Like
1 Like

In my machine, it just show blank section like this

Any idea how to fix that? I’m using latest Clear Linux buid on 41430

You may need to install gnome-remote-desktop. No, it doesn’t come preinstalled with your run-of-the-mill CL.

I see. I get it after install gnome-remote-desktop bundle. Thanks, Mister

I have been able to get a little further with xrdp. I authenticate into a blank window, I have to X out of
the windows rdp session in order to kill it.

# Perform all of these commands as root or use sudo for each command
# Install xrdp and development package that goes with it
swupd bundle-add xrdp
sudo swupd bundle-add devpkg-xrdp
# Create configuration directories needed 
mkdir -p /etc/xrdp
cp /usr/share/defaults/xrdp/xrdp.ini /etc/xrdp/
cp /usr/share/defaults/xrdp/sesman.ini /etc/xrdp/
# This command is really needed so authentication with users login in with rdp
cp /usr/share/pam.d/xrdp-sesman /etc/pam.d/.
#  Modify startwm.sh to invoke what is needed for Clear linux Server/Host
# Help needed here....
cp /usr/share/defaults/xrdp/startwm.sh /etc/xrdp/startwm.sh
# Enbale start 
systemctl enable --now xrdp
# Note may not need this command the xrdp service starts it
systemctl enable --now xrdp-sesman 

There are scripts and ini files that need to be configured for clear Linux.
Can gnome-remote-desktop be invoked from startwm.sh after the .ini files have
been setup

Has anyone done this already?
Is gnome-remote-desktop supposed to be the remote desktop server and xrdp server is not needed?

@arjan said that all the bits should be in the build now, but remote login isn’t working out of the box for me with build 41530. So I have my fingers crossed for the next release.

_Still no remote login in 41530 :frowning: options are greyed out. _
<arjan_work> pixelgeek: it’ll land in the release after
<arjan_work> pixelgeek: 530 was the format bump build (so same bits as the old build)


1 Like