How to add a printer

How to add a printer. It is empty under settings / printer / add a printer.
Found an .ppd file for the old printer at http://www.openprinting.org/printer/Samsung/Samsung-ML-1210
am I helped by this?
Read somewhere that drivers should be pre-installed in the Linux kernel. But how is it in Clear Linux?
Can any kind soul guide me with this?

Printer drivers are part of the CUPS subsystem, not the kernel. You should be able to add PPD files in /etc/cups/ppd/ (create the directory if necessary).

Also check the vendor’s website for drivers. Sometimes they are shipped in RPM format, and you may still be able to install it.

I have now added the file Samsung-ML-1210-gdi.ppd using command: sudo mv ~ / Downloads / Samsung-ML-1210-gdi.ppd / etc / cups / ppd /, which worked. But, under settings, printer, add a printer, becomes the answer; no printers were found.
Am I doing something wrong?

Not working. I have edit this part below: "found this: https://support.hp.com/us-en/drivers/selfservice/closure/samsung-ml-3312-laser-printer-series/19134876/model/19134878?ssfFlag=true&sku=

Samsung Print Driver for Linux 14.8 MB wool_V1.00.39_01.17.tar.gz

but don’t know how to install it?"

2020-05-30
Edit the following: the link above was broken. This link is to the file I have downloaded, and don’t know how to install.

http://downloadcenter.samsung.com/content/DR/201704/20170407143829533/uld_V1.00.39_01.17.tar.gz

Tried to install the following file

Install-printer.sh

Result
Registering CUPS backend …
**** CUPS restart FAILED.
**** Print driver has been installed successfully.
**** Install finished.

Doesn’t work
No printer found
???

Can you attach the script so I can take a look?

You mean the following I suppose?

#!/bin/sh

SCRIPTS_DIR=$(dirname “$0”)/noarch

load ‘scripting’ run-time support utility functions

. "{SCRIPTS_DIR}/scripting_utils" script_log_init (basename “$0” “.sh”)

load ‘package’ run-time support utility functions

. "{SCRIPTS_DIR}/package_utils" environment_init (basename “$0” “.sh”)

if sh “SCRIPTS_DIR/pre_install.sh" "@” ; then
sh “$SCRIPTS_DIR/package_install.sh” “printer-meta”
sh “SCRIPTS_DIR/post_install.sh" "@”
fi

Do you run it with sudo?

Yes I did run it with Sudo.

with lsusb is detected?

Sorry for the late reply.
But don’t know how to use isusb?

Error: unrecognized subcommand `isusb ’

locate isusb
/usr/lib/modules/5.7.4-964.native/kernel/drivers/usb/misc/sisusbvga

It’s lsusb (starting with lowercase L)

Aha, ok

Got this result with sudo lsusb
The printer was plugged in and started up.

Bus 002 Device 003: ID 0781: 5583 SanDisk Corp. Ultra Fit
Bus 002 Device 002: ID 0781: 5583 SanDisk Corp. Ultra Fit
Bus 002 Device 001: ID 1d6b: 0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 064e: 9700 Suyin Corp. Asus Integrated Webcam
Bus 001 Device 002: ID 8087: 0a2a Intel Corp.
Bus 001 Device 001: ID 1d6b: 0002 Linux Foundation 2.0 root hub

its an old printer,i thing you using wrong driver,maybe the " splix" driver it works for yout model…

Thanks for the suggestion.
As always when I test install with “for rpm in openprinting-splix-2.0.0-2lsb3.2.x86_64.rpm; do rpm2cpio $ rpm | (cd /; sudo cpio -idv); done”

then I get the error message: “cpio: premature end of archive”
So I failed to install the driver.
And of course it is an old printer, but works well for my purposes.

As pasted above, you have an extraneous space between $ and rpm; should be as follows:

for rpm in openprinting-splix-2.0.0-2lsb3.2.x86_64.rpm; do rpm2cpio $rpm | (cd /; sudo cpio -idv); done

That gap occurs when I paste into the browser. So it is not that way when I paste into the terminal. Would have gone through and adjusted this in the browser of course, but did not think about it.
So the error message is valid at this time.

Changed | to ; in the command, which gave the following response

rpm2cpio: command not found

To install rpm2cpio use: sudo swupd bundle-add package-utils

Now the following appeared with sudo lsusb

Bus 001 Device 005: ID 04e8: 300c Samsung Electronics Co., Ltd ML-1210 Printer

But when I try to add a printer via settings / printer / add a printer, no one is found.

good ,lets try: " gpasswd -a yourusername lp"
then : " systemctl start cupsd.service" and “systemctl enable cupsd.service”
Open up the following URL in a web browser “http://localhost:631/”.
connect with username and password,go to “administration” and add your printer model if everything ok

Started with:
sudo gpasswd -a myusername lp

Results:
Adds the user myusername to the lp group

In the terminal:
Created symlink /etc/systemd/system/printer.target.wants/cupsd.service → /usr/lib/systemd/system/cupsd.service.
Created symlink /etc/systemd/system/sockets.target.wants/cupsd.socket → /usr/lib/systemd/system/cupsd.socket.
Created symlink /etc/systemd/system/multi-user.target.wants/cupsd.path → /usr/lib/systemd/system/cupsd.path.

Ok so far

Instruction:
Open up the following URL in a web browser “http: // localhost: 631 /”.
connect with username and password, go to “administration” and add your printer model if everything ok

After opening the url “http: // localhost: 631 /” I must first click on “administration” to be able to enter the username and password.
After this is done, nothing happens. I lowered the security settings in the browser without any help.
Added UDP / TCP to the firewall according to http: // localhost: 631 / help / firewalls.html Table 1: Ports Used for IPP Printer Sharing

The “administration” page was now opened.


Saw the following message “Unable to open cupsd.conf file:” when I opened “administration”, which by the way took a long time.


Apparently no printer found.

List Available Printers
Available Printers

No printers found.

Under Add Printer is the following:

Local Printers: HP Printer (HPLIP)
Discovered Network Printers:
Other Network Printers: Backend Error Handler
Internet Printing Protocol (ipp)
AppSocket / HP JetDirect
Internet Printing Protocol (https)
Internet Printing Protocol (ipps)
LPD / LPR Host or Printer
Internet Printing Protocol (http)
Canon network printer

Under Add Printer is the following:
Connection:
Examples:

http: // hostname: 631 / IPP /
http: // hostname: 631 / IPP / port1

IPP: // hostname / IPP /
IPP: // hostname / IPP / port1

lpd: // hostname / queue

socket: // hostname
socket: // hostname: 9100

See “Network Printers” for the correct URI to use with your printer.


Tested adding printer HP, could in this connection choose Samsung ML-1250 (eg.ML-1210) but this did not work.

Printer HP appears to be loaded (visible under printer) and print jobs appear to start in the “computer”, but nothing is printed.

Driver: Samsung ML-1250 - CUPS + Gutenprint v5.3.3 (grayscale, 2-sided printing)
Connection: http: // hostname: 631 / IPP /
Defaults: job-sheets = none, none media = iso_a4_210x297mm sides = one-sided

The printer is connected through USB.