Rescue a non booting system

My clear linux install hangs on boot with no error messages. Booted fine for month before the issue started. I have tried booting with a CL usb drive and trying to repair using swupd per docs with no success. Reported files were copied and deleted but no change at boot. I also tries rolling back to the previous release per docs with no success. Still stuck with a non booting system and can find no other guidance to recover. Any and all help is appreciated!

I could’t boot to gui a few days ago, but I could get into a terminal when it hung.

I’m not sure of the exact key, but I’d stroked the F keys and the top couple of rows and got a command prompt

wifi worked after typing $ wifi on

what fixed my boot problem was installing the complete kde-desktop package

now I seem to have the KDE login shell rather than the gnome one, but it logs me into gnome.

It could be a hardware issue. You can report a bug to developers, but before you can choose another distros with older Linux core and 5.18 to check a problem. If it works fine, report a bug with a description of your system specification.

Hi,

There is an issue with latest 5.18 kernel when use md raid ( software raid ) . Kernel 5.18.2-1151 and mdraid volumes

If that is your issue you need to add /etc/mdadm.conf or revert the active kernel or the as I did installed lts kernel.

Adding /etc/mdadm.conf could be the simplest and faster option.
if decide to to with LTS kernel and you are you using - Fix a broken installation — Documentation for Clear Linux* project documentation,
I would say to mount BOOT partition (in /mnt/boot after root is mounted ) if manipulate the kernels
sudo swupd bundle-install kernel-lts --path=/mnt --statedir=/mnt/var/lib/swupd

Good luck

2 Likes

No hardware issue, Arch boots fine with 5.18.3

Thanks, Sadly no luck so far! Installed lts kernel but has same results at boot. I do have software raid but not active when booting into CL, added mdadm.conf anyway but no change at boot. I am always willing to try new distro’s and loved the speed but if a system cant be recovered its a dead distro imo!

One more thing to try, as a stab in the dark – look for /boot corruption: Recovering from /boot weirdness

Obviously boot from USB to try this.

Tried that too, no luck!

Mine never gets that far in the boot process, no prompt on any console.

Going to give it one more day for suggestions and then move on from Clear Linux. The ability to rescue a system is critical for it to be used. Arch user for over a decade with years of debian and ubuntu experience also, have not had a system I could not rescue in over 15 years!

thank you for your answers