Safe installation fails because of seemingly a typo in installation commands that installer runs

Hi, I never tried Clear Linux before (but have general Linux experience), and I ran into a problem installing it on my machine. Before trying to install it I made sure that my hardware supports it, it boots into Live USB without any problems, but installation throws an error as soon as it starts. I check the log, and it looks like there is a typo in the command.

(Please don’t pay attention to warning “[WRN] Failed to find EFI firmware, falling back to legacy BIOS for installation.” I tried to run it in UEFI mode, in Legacy, and none of boot modes helped in installation, there is the same error)

There are the lines that seems to be the root of the problem:
[DBG] parted: invalid token: EFI
[DBG] Error: Expecting a partition type.
[DBG] WritePartitionTable: mkPartCmd: mkpart EFI fat32 463333M 463489M
[DBG] parted -a optimal /dev/sda unit MB --script – mkpart EFI fat32 463333M 463489M

For me, it looks like a typo. I guess there should not be space between – and mkpart? So mkpart is a parameter and EFI is parameter value?

EFI is the token that is invalid, and partition type should be primary or secondary.

Also in your log is

2021/06/16 19:01:22 [DBG] WritePartitionTable: partial disk, skipping mklabel for sda

I think this means you have a msdos disk label, and apparently the installer does not support that.

Normally the installer would mklabel gpt but couldn’t because you didn’t want it to wipe existing partitions.

Looks like the EFI token is invalid because of the typo. It expects a partition type where it doesn’t pass the assigned mkpart parameter to parted

No it can’t have a msdos disk label, because that drive had Ubuntu installed on it, on the same partition, that I, however, previously wiped and deleted, so it was unallocated space that Clear Linux was supposed to take and use

1 Like

lines 41, 60, and 86 in your log say otherwise

2021/06/16 18:59:33 [DBG] /dev/sda: msdos partitions 1 3 <5>
2021/06/16 18:59:33 [DBG] setPartitionTable() line is "/dev/sda:1000204886016B:scsi:512:4096:msdos:ATA WDC WD10SPSX-22A:"
2021/06/16 18:59:35 [DBG] FindSafeInstallTargets: ignoring disk sda with partition table type dos

Either allow CL installer to do a “Destructive Installation”, or you need to reformat the drive gpt yourself

If there’s a bug in the installer it might be it’s failure mode is not working as intended. I’m guessing it was supposed to fail after it couldn’t find any gpt formatted disks, but it continued anyways.