Version 33070 problems

After updating to version 33070 Clear Linux was broken. On reboot black screen frozen curser requires hard reset. Had to reinstall Clear Linux worked fine restarted and booted to desktop. Repeated 33070 update and again it broke Clear Linux. Any fix for this issue??

1 Like

Do you have AMD GPU?

When GUI fails to start, switch VTs to see if text console is usable before resorting to a hard reset:

https://www.tldp.org/HOWTO/Keyboard-and-Console-HOWTO-7.html

Yes AMD Radeon R9 Fury series PC locksup no keyboard black screen frozen mouse pointer

Same here. Standard issue amdgpu that came with NUC8i7HVC (Radeon RX Vega M GH Graphics). Same issue. Is CL no longer working with amdgpu? All my desktop systems run on this same setup. Not due for hardware upgrade till the end of the year. (Will then have the new NUCs with intel GPU) .

1 Like

Same here. Using a Debian-Live USB disk doesn’t work either, looks like you have to use the Clear Linux live ISO, boot, and run swupd repair --picky

Hmm. How is that different from switching to text console with Cntrl+Alt+F3 and running

 swupd repair --picky

Which I tried and didn’t work for me? (just cleaned out a few rpms which can easily be restored, possibly to a better location).

Well, hopefully the Clear Linux Live ISO will be a different version so it will boot at all. I believe the issue is with version 33070 and the ISO holds version 33060. But you’re right about swupd repair --picky - that likely isn’t what I want.

I see. I took this to be the same as my issue.

Which isn’t really a boot failure. X and other desktop services just crash and leave you with a blank screen and a frozen mouse pointer. Console is still available. Journalctl shows amdgpu errors and various gnome and gdm dependency errors in my case.

Come to think of it, I didn’t actually try the Ctl-Alt-F3 command to reach the console, I just rebooted, which was a mistake.

yeah everything else is still intact in all of my systems namely the dev libs. Still pushing from my daily driver using vim, ide’s over ssh, and other tools.

1 Like
sudo swupd repair --picky -m 33060

Worked for me. Quick and dirty (unsupported) fix rolls back version. I left autoupdate on – I don’t plan to reboot till there is a fix released! If you don’t use a UPS you may want to temporarily disable autoupdate. Current release is 33080.

2 Likes

Looks like Intel doesn’t want any machines with AMD gpu’s to run Clear Linux, This 33070 update also affected the bios and was unable to access the bios until clearing rtc ram. What are Clear Linux’s programmer;'s trying to tell us will have to stop using Clear Linux until they make up there mind’s.
Disappointed .

Nah it’s just a bug. They are working on it. I’m sure they’ll have it fixed soon.

I think you are right appears to be a bug only affecting certain AMD gpu’s will have to wait until they sort it out

You can track progress here. Github Issue

2 Likes

You think 33080 is too soon for a fix??

How will we know will they post something?

I’m sure they will post something on the github issue. Maybe close the issue when it’s resolved. I can confirm though that as of 33080 it is not fixed.

@ahkok any chance we might see a fix for this in the next release? If more data is needed I could maybe try reboot one of my machines and send over the systemd logs.

We are tracking the issue in github, please follow https://github.com/clearlinux/distribution/issues/1964